0

The catalog paths don't appear in the xml sitemap with ubercart 3 and drupal 7. How can this be done.

  • A similar discussion on drupal.org which may help you, drupal.org/node/425984 – Anoop Joseph Mar 20 '13 at 7:35
  • I did come across that discussion myyself. However its for D6, it also refers to a D7 discussion but the patch there is maked failed for testing. – DD dev Mar 20 '13 at 8:28
  • The issue above (425984) indicates that 1909542 fixes the problem in D7 - and it was committed by longwave on 6 Feb. Have you tried the dev branch of the module? – Adam Balsam Mar 22 '13 at 15:17
  • Actually, that patch is in 7.x-3.4 so as long as you're using the most recent version, that patch is in there. I just did a quick test, and XML sitemap does include paths to the catalog, but they are the generic /taxonomy/term/n paths, not /catalog/term. – Adam Balsam Mar 22 '13 at 18:12
0

Make sure that you have XML sitemap node enabled.

Go to /admin/structure/types and make sure that your product type in set for inclusion in the XML Sitemap by default. If you have to change it, then if the pages you already have are set to 'default' they will react properly. If they are set to 'exclude' you will have to edit each page and change it.

Then go to /admin/config/search/path/patterns and set your catalog path to catalog/[term:name] and your catalog product page paths to catalog/[term:name]/[node:title].

If you have to regenerate your aliases, make sure that you retain the old alias, or use the Redirect to issue a 301 redirect for old aliases.

Then regenerate the site map. These steps should cover off any reason why the paths are not in your current sitemap.

  • Catalog is not a node and neither a contenttype – DD dev Mar 23 '13 at 7:13
  • If you are talking about including the view paths for the catalog views, then those are taxonomy paths. (Looking at your previous question maybe you should rethink your decision to turn off taxonomy paths.) Same arguments as above, but make sure ""XML Sitemap taxonomy** is activated, set your vocabulary for inclusion and regenerate your site map. Or you could use XML Sitemap custom and manually include any specific paths you want. – Triskelion Mar 23 '13 at 12:24
  • I know that they are texonamy paths however the xml sitemap module doesn't check the subtype. If i adjust the machine path in xml sitemap i works but thats not a nice solution. I think there should be a xmlsitemap_ubcercart of catalog module – DD dev Mar 23 '13 at 13:16
  • Actually uc_xmlsitemap is a great idea for a contrib module. I am sure you could get space on GIT to set up and start work on it. – Triskelion Mar 23 '13 at 14:11
0

Updating to 7.x-3.4 solves this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.