2

For just one of my content types -- the built-in Article content type -- the node option vertical tabs at the bottom of the add / edit form are not displaying correctly.

As shown in the attached screenshot, the first node option for whether to create a menu link for the node is displayed as a tab. All other node option fieldsets are displayed WITHIN the first vertical tab as collapsible fieldsets, not as additional tabs. This only happens for the Article content type.

I cannot figure out why this is happening. Clearly, some module is form_altering the node add / edit form, but I have no idea which one or why only for Article.

  • where is screenshot? – monymirza Mar 22 '13 at 5:50
  • Were you ever able to find a solution, or offending module? – salihcenap Jun 14 '16 at 9:52
  • I cannot see the screenshot here either, unfortunately... and I would suggest 2 things; dumping a list of contrib modules using drush and reviewing them carefully, and searching the contrib code for a _form_alter. (ie using grep in the contrib directory) – Adam John May 12 '17 at 23:37
0

Here is a series of things I would try. Check tabs after each test.

  1. Try with a different browser.
  2. Flush all caches (that one often solves a lot of problems).
  3. Put your site in maintenance mode and Run updates (update.php).
  4. Disable the Overlay module.
  5. Disable all modules. Flush all caches. Re-enable all modules.
  6. Update to the latest version of core if you can (currently 7.22).

Number 5 is a bit time consuming but it has solved issues for me in the past. First, make a list of all enabled modules. I do this with screen captures. Second, start disabling modules (except maybe Admin menu). You won't be able to disable all modules at once. It may take half a dozen Save configuration to completely disable all modules. When done, Flush all caches and while you're at it, clear your browser's cache too. Finally, re-enable all required modules. Run updates. Run cron. Flush all caches.

Hope this helps.

0

On the content type's configuration page (eg: yoursite.org/blog/admin/structure/types/manage/article/fields), make sure you have nested your tabs correctly. Each vertical tab should be within a vertical tab group. Drupal treats the administrative tabs (like menu items, authoring, etc.) as a tab group, but if your other tabs are free-floating, they'll all go together.

On your Manage Fields tab, scroll to the bottom and create a new group, selecting Vertical tabs group option. See screenshot below. Then put your node's fields inside the group. The admin tabs will be outside it and will go into their own group.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.