3

I am adding alphabetical page to the view using glossary mode. I am able to create the alpha pager but the issue is, when I click on the alphabet the alpha pager doesn't appear again. I have to go back to view the alpha pager.

  • I am looking for this too. I managed it with some nasty HTML method. Waiting for a better answer. – niksmac Mar 26 '13 at 12:20
  • Nikhil can you share your mehtod . – B L Praveen Mar 26 '13 at 13:18
1

From what I remember, you have to create the Glossary display of the view, and then you set the results page as an Attachment of that view display (attachment being the view display type).

Views ships with a default Glossary view, it's just disabled. I would suggest enabling that and take a look to see how that does it.

  • Chapabu Can you give some idea or link how to create Glossary view and were to enable the default glossary view – B L Praveen Mar 27 '13 at 5:05
  • @BLPraveen If you head to the Views list, then scroll down to the bottom. There will be a view called Glossary (or similar) that is disabled by default. You can either enable that View or clone it and edit it to fit your requirements :) – Chapabu Mar 27 '13 at 9:51
1

I found the solution to this problem. This link explains how to resolve this issue http://drupal.org/node/349739

  • @B L Praveen That link is about Drupal 6. Any idea how to fix this on Drupal 7? – CocoSkin Mar 28 '15 at 13:50
  • Its longback I had this issue with one of the website. I never looked it back again.If I could look into the website I can find a solution. I cannot setup on my system to test it. – B L Praveen Mar 28 '15 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.