3

I've managed (after a lot of struggle) to create a view with four exposed filters (all filters are taxonomy fields). My problem is that now by default no data is presented to the user whene the page loads and data appears only when a filter term is chosen. I'm trying to achieve the exact opposite: have all data presented and then filter it accordingly. how can i do it?

2 Answers 2

2

When editing the filter, you can choose to require it if it's a select type of filter, you can also provide a default filtering that's used (before the user inputs). My guess is that you need to tweak these settings. to make sure that the default view filter settings display all or a selection of your choosing.

2
  • But should i add "optional filters" from the "contextual filters" menu or from the "Filter criteria" menu? Commented Jul 12, 2011 at 8:08
  • The problem was in "Exposed form style" - i had selected "input required" instead i should have selcted "base" Commented Jul 12, 2011 at 8:26
1

I came-across this one as I had same problem too when googling for the solution. I managed to solve this with Drupal 8; for Drupal 7, it should be the same.

On any exposed filter that you set, choose Contains any word from Operations.

1
  • and additionally, on "Exposed form style" it should be set to "Basic". Cheers
    – ardnet
    Commented Feb 1, 2017 at 11:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.