0

I have just been trying to get twitter going on my drupal 7.21 website. i followed the tutorial at http://drupal.org/node/1346824 Everything was fine until the last step of authorising a twitter account, when i got a blank page back from the twitter app and a message saying "unauthorised oauth request". I've tried re-installing, messing with callback URL's etc but cannot get anything to work. Has anyone else solved this problem? Thanks Andy

  • Is your server behind a firewall or running a proxy? We had similar issue with OAuth tokens not being generated (check the URL when you get a blank page, it should have like oauth_token= (blank)) which generally means there's a problem with firewall or misconfiguration – Beebee Feb 28 '14 at 11:57
1

After the new Twitter API upgrade, I would recommend using the Twitter Pull sandbox project. It works beautifully.

|improve this answer|||||
0

make sure to put correct "OAuth Consumer key" and "OAuth Consumer secret" from admin/config/services/twitter/settings

|improve this answer|||||
  • Thanks Sharef, I had managed to do that bit....it seems to talk one way to twitter, but can't cope with the return handshaking. IS there a need to set some kind of special "context" do you know? – Andy Apr 11 '13 at 4:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.