0

I'm using wyswig and ckeditor with media module to insert images into the body field of a node.

Instead of displaying the image it displays a link to the image. Viewing source this is what is inserted:

<p><span class="file media-element file-default" data-file_info="%7B%22fid%22:%2213%22,%22view_mode%22:%22default%22,%22type%22:%22media%22%7D"><img alt="" class="file-icon" src="/modules/file/icons/image-x-generic.png" title="image/jpeg" /> <a href="http://dev.charm.ucsf.edu/sites/dev.charm.ucsf.edu/files/feature_MB2.jpg" type="image/jpeg; length=22001">feature_MB2.jpg</a></span></p>

I have "Convert Media tags to markup checked" and I am NOT limiting HTML tags. Any ideas why it's stripping out the "[" and "]"?

Thanks, Jon

  • You should have a look at the Insert module. – Triskelion Apr 12 '13 at 17:54
  • Have you tried Full HTML in field ? – niksmac Jun 2 '13 at 6:07
  • What version of Media are you using? – aburke626 Jul 11 '14 at 18:28
  • What do you mean by "stripping out" the brackets? The media button on the editor will insert JSON that describes what display mode you want to use. Then, when the node is rendered, the "Convert Media tags to markup" input filter converts that JSON to the appropriate HTML, in line with the display mode. If I'm understanding your question correctly, you should select the answer by @6c1 – UnsettlingTrend Feb 5 '16 at 20:14
2

You can fix this in the web admin GUI:

Configuration > Media > File Types > Image > Manage File Display > Check the "Image" box.

0

Not sure if you've found a solution by now, but I had the same issue and it turned out to be panels that was causing the problem. To solve this, I went to Page Manager > My Variant > Content. I then chose the piece of content that had the image in it and in the settings changed the formatter to 'Rendered File' and chose the view mode 'Large' (it had been 'Rendered File': 'Default', which displayed the link to the image rather than the image itself). I hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.