0

I was getting fatal error to do with ctools along the bottom of each page of my site. To try to fix the issue I logged in as admin, and disabled 3 ctools modules in my website:

  • Custom Content panes
  • Page manager
  • Views content pane

This gave me an error page and my site is totally inaccessible or viewable. I turned them back on manually in the database, but now I get this error message:

Fatal error: Call to undefined function page_manager_get_task() in /var/www/mywebsite.com/httpdocs/sites/all/modules/ctools/page_manager/plugins/tasks/page.inc on line 266

Does anyone know how to fix this?

  • enable page manager module – Aboodred1 Apr 14 '13 at 23:36
  • can you share with us the error message you've got after disabling the 3 ctools modules from the admin section. – Aboodred1 Apr 14 '13 at 23:38
  • The issue has evolved. I've go the site back online but I think the root of this problem is I created a backup of the ctools folder called 'ctools BACKUP' and left it on the ftp space. I can log in as an admin but when I click on the 'modules' button I get this message: Fatal error: Cannot redeclare ctools_export_ui_process() (previously declared in /var/www/mysite.com/httpdocs/sites/all/modules/ctools BACKUP/includes/export-ui.inc:13) in /var/www/mysite.com/httpdocs/sites/all/modules/ctools/includes/export-ui.inc on line 363 – Darren Baker Apr 15 '13 at 12:16
  • there is also a security update available for ctools from 7.x-1.2 to 7.x-1.3 which I haven't done yet. – Darren Baker Apr 15 '13 at 12:19
  • you can't create a backup for a module in drupal directory because drupal checks every folder to see if it contain .module file. so move your backup to anther directory other than drupal's directory – Aboodred1 Apr 15 '13 at 16:43
0

Its really hard to figure out a solution for your issue without trying different options; but I hope the following instructions will help you.

  1. Backup your current database
  2. Open phpMyAdmin or any desirable MySQL administration tool.
  3. Delete all ctools modules from system table or run this query

    DELETE FROM system WHERE name LIKE '%ctool%'

  4. Drop ctools tables ctools_css_cache, ctools_custom_content, ctools_object_cache or run these queries

    DROP TABLE ctools_css_cache

    DROP TABLE ctools_custom_content

    DROP TABLE ctools_object_cache

  5. truncate all cache tables (cache table and all tables with prefix cache_), example of truncate query

    TRUNCATE TABLE cache

  • Hi, thanks for your advice. After deleting the ctools backup folder I then run the database update tool. Everything now seems to be working correctly. I will keep a copy of your instructions above as they may be helpful in future. Thanks for all your help with this issue - the nature of the internet makes it very easy for us to forget to say thanks to complete strangers who help out for free - so THANK YOU!!! – Darren Baker Apr 17 '13 at 15:01
  • You are welcome! When you ran the database update; Drupal already cleared it cache. Glad it worked for you. – Aboodred1 Apr 17 '13 at 17:06
0

I had the same problem earlier today and this worked for me......

  1. run update.php and update your drupal installation like so http://www.example/update.php or localhost/update.php
  2. follow the instructions and update all modules as needed

Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.