0

Ok, I'm on D7 and using the default Bartik theme. I set comments for content type Article to be 10 per page, threaded. I published a test Article and started commenting to test the paging, and when I surpass the set limit of 10 per page, the article only displays the first 10 comments and I don't see a "more" or a "next page" or anything linking to the second page of comments.

I did not touch any PHP or CSS.

5
  • Those same settings for me on D7, Bartik theme do indeed produce a paged set of comments. So it's not the theme or module - they definitely implement that. Any idea what customizations you may have on your site that you aren't thinking of? Apr 15 '13 at 14:10
  • I'm on Drupal 7.20 by the way.. Apr 15 '13 at 14:13
  • Uh-oh. I think I found something broken in my Drupal. When I go to Administration>structure>pages and hover over the comment_reply entry, the popup says something completely unrelated: "When enabled, this overrides the default Drupal behavior for the site contact page at /contact. If no variant is selected, the default Drupal contact form will be used." This is not what I expected!! Something seems to be really out of order!
    – supadroopa
    Apr 15 '13 at 20:29
  • I can confirm this ("When enabled, this overrides the default Drupal behavior for the site contact page at /contact. If no variant is selected, the default Drupal contact form will be used.") hovering over the comment_reply entry on one of my 7.22 installations. Except, the paged output of comments is working.
    – Volker
    Apr 15 '13 at 20:54
  • hmmm... the plot thickens...
    – supadroopa
    Apr 15 '13 at 22:12
0

This was cross-posted to the Drupal Sub-reddit. Just posting here for any future googlers:

If you have more than one pager on a page (think a views block of recent content) you have to give it a unique Pager ID which you can do in the advanced settings for the pager in views.

1
  • Yes, that was my problem. I had a Views block whose pager ID conflicted with the pager ID of the content block. Removing the Views block gave me back the pager, and editing the pager ID of that block solved the problem fully.
    – supadroopa
    Apr 16 '13 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.