1

I facing issue with OG 7.2x and image.

I create a group content type and add new field with image. After that i upload some picture, and view with colorbox working fine.

After that, i create normal view all things is workings well. if i add contextual(OG member:group id) and relationship(member from og node), the picture disappeared and nothing display under OG view.

Would you please tell me that how to do this?

Many thanks.

0

Hi what you can do is that create a content pane from a view display and configure it in the following screen shot listed below.

OG View for displaying content

Next in the fields section you can add the image field and other fields as per you like.

enter image description here

 ![Add fields accordingly][2]

Also you can clone the view that comes default with OG.

OG:CONTENT(clone this view and add fields)

Hope this helps. :)

Edit:- For displaying images

I havent done anything like this before. But I think you can do this by "rewriting" the result of the url field.

You can do this by clicking the field with the url that you will find under "FIELDS" in your view settings. Then under "Rewrite Results" you can write something like

<img src="[image_url]" />

here, 'image_url' must be the name of the field. you can verify this in the list displayed under "Replacement Patterns"

Hope this helps. :)

| improve this answer | |
  • the Pictures still not display. when i following you step, the image field name appeared,but pictures not displayed. – yutaolife Apr 16 '13 at 6:34
  • @yutaolife Have edited my answer above and added for displaying images...just try if that works. – Prerit Mohan Apr 16 '13 at 6:40
  • Also if you are using Image field type you can try and Click the '+' sign next to Relationships and you should most likely find one under 'Image'. Once a relationship is set up then you should see image in your fields. @yutaolife – Prerit Mohan Apr 16 '13 at 6:53
  • Another helpful resource metachunk.com/blog/adding-related-content-view-drupal-7 – Prerit Mohan Apr 16 '13 at 6:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.