0

I have a view block that shows a sub-set of nodes. In the configuration page, the autopreview section shows content, so I know the filters for the view are set up correctly. I configured the block to show on only the listed pages and entered <front> for the page. Unfortunately, the front page shows only the following content and a static block.

No front page content has been created yet.
•Add new content

The weird part is that this static block is configured the same way the view is configured to show only on the front page.

Why doesn't the view block appear on the front page?

  • What kind of filter did you configure? If it's some sort of contextual filter, you probably have to check your settings for whats happening, when the value is not available in the url... – Volker Apr 16 '13 at 21:43
  • You may read this: drupal.stackexchange.com/a/13681/7086 – Volker Apr 16 '13 at 21:50
  • No contextual filters on this view. The filters are set up under the filter criteria section and just specify the content type and to retrieve only those items that expire after now (expires is a date field in the content type). – Robbert Apr 16 '13 at 22:02
  • 1
    Try changing Visibility settings/Pages to 'All pages except those listed' and make sure the field below is empty. Now what do you get? I you still get nothing, what are your 'Filter criteria' in views? – Bisonbleu Apr 17 '13 at 1:13
  • 1
    Okay, color my face red. Turns out I had a checkbox checked to display the view for only a specific content type. Unchecking it fixed the problem. – Robbert Apr 17 '13 at 16:24
0

There is something else you should check. If this is a new site, and you have newly named regions, make sure that the regions have underscores (instead of dashes.) If you need to convert any dashes to underscores, you'll have to reassign and re-enable the blocks on the Structure > Block Layout page.

| improve this answer | |
-1

Try setting your block to only display on on /node
Thats what I had to do on my Drupal 8 site for things to show up on the front page. Also if you want the:

No front page content has been created yet.


 •Add new content

To disappear, you'll need to edit the 'Frontpage' view and get rid of those values from the view.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.