1

I tried to update my installation, but now I'm getting this fatal error:

Fatal error: require_once() [function.require]: Failed opening required '/home/abel/www/lmwep/massteri/sites/all/modules/views/includes/admin.inc' (include_path='.:/usr/local/PEAR:/usr/local/share/pear:/usr/local/lib/php') in /home/abel/www/lmwep/massteri/sites/all/modules/views/views_ui.module on line 175

I have no clue what this means. Any help is appreciated.

  • I had a similar error and the root cause for me was that my Drupal database data in (MySQL) was the wrong version for the Drupal PHP code. when I say 'version' I'm referring to an internal version used by our dev team, not Drupal version. So the solution was to use the later code that was meant for that database. Hope this gives some useful ideas to folks who look online for solutions to this problem. I guess the reasoning is that the database included references to code that I did not have. – therobyouknow Oct 28 '13 at 13:10
3

It means that the file admin.inc (part of the Views project) is not found.

This file is supposed to be on the following path below your Drupal root sites/all/modules/views/includes/. If you check, I'm sure that you'll find that it is no longer there.

Why this happens is more difficult to say. I presume that you had the Views module installed on your site in sites/all/modules/views/ as indicated by the path (for the record: this is the right place), but that after the upgrade, it is no longer there? Again, please check?

When upgrading, the sites subdirectory from the pre-upgrade site is supposed to be the sites subdirectory in the upgraded site. If this, for some reason, in not the case, the contributed modules you've installed (such as Views) will be lost.

Please check if the files are missing (as I belive they are). If they are missing, the solution is to make sure that the entire sites subdirectory hierarchy is properly moved into the upgraded site file hierarchy.

| improve this answer | |
  • Thanks. Indeed, there's no an includes directory on that path...do you know how can I solve that? – user2167799 Apr 21 '13 at 6:01
  • the system prompted me to upgrade...I didn't copy anything...I just followed the automatic update process – user2167799 Apr 21 '13 at 6:06
0

please first clear your cache by drush cc all or clear your cache table from database then run your site.

| improve this answer | |
0

Try re-installing views module or the module which causes this issue. It worked for me.

Hope it would help someone running with this kind of issues.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.