In Drupal 7, how do I let the users with a specific role add new articles?

I logged in as administrator, set the permission for the role to allow creating and editing nodes that are articles.
When I login with a user with the role, for example, "NewRole," I do not see any control or dashboard that allows me to create new articles.

How do I start adding new articles as this new user?

2 Answers 2


You probably don't have the Navigation menu enabled/placed in a region, or have any other links to direct a user to the Create Content page.

As an administrator, either enable that menu or create a link to "node/add" (to allow the users to see all the content types for which they can create a node); you can also add a link to "node/add/article" in another menu or in your theme.

To allow a user to see the administration toolbar, they must have a role that has the permission to use the administration toolbar. See below:


  • awesome....so for ANY user, you can go to http://mysite.com/node/add to add any content type. THANK YOU! Commented Jul 14, 2011 at 17:51
  • Yes, any user that goes to example.com/node/add will see all the content types they can create in a list, then click on a link and see the node form.
    – Laxman13
    Commented Jul 14, 2011 at 19:33
  • I followed this but still get "Error The website encountered an unexpected error. Please try again later." when the user follows link
    – Sam
    Commented Jul 2, 2015 at 23:46

You must set the right permission! Now i give to you a screenshot enter image description here

enter image description here

If you set the permission for example as the screenshot the user will modify article type content.

  • Sorry, see the Laxman13's response, i dont read well your answer Commented Jul 14, 2011 at 17:46
  • Hey Giovanni, I tried your settings and the black Admin Dashboard still doesn't show up for users with MyRole Commented Jul 14, 2011 at 19:20
  • @John if you mean the toolbar across the top that has administrative links, in order for a user to see it, they must have a role that has the permission "Use the administration toolbar". See the edit in my answer for the picture example
    – Laxman13
    Commented Jul 14, 2011 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.