1

I added the CAPTCHA module to my drupal 6 website using this procedure and I'm trying to add the captcha to my user registration page.

However when I go to /admin/user/captcha the list with the default forms is empty. I expected the default list.

I entered user_register as the form_id, selected the standard captcha from the dropdown and pressed save. However it does not add the new form to the list. It's still empty. I also tried to save other values without success.

UPDATE: I also tried reinstalling the captcha module and flushing cache without success. It's weird because I never had this problem on an other site with the same module/version

Installed version of the module: 6.x-2.4

UPDATE 2: I enabled both the Captcha module and the Captcha compatibility module in the modules list.

0

The problem was the site didn't have writing permissions to the database. This meant that on installation of the module the necessary tables where not created and thus the above problem occurred.

  • Im having the same problem. What do you mean with "the site didn't have writing permissions to the database"? Makes no sense for me, since Drupal can create tables in my database. Can you give me more detailed information? Thanks in advance. Diego – user19435 Jul 22 '13 at 15:29
  • The database was closed for doing actions like adding columns to a table for security reasons. After I gave the permissions on database level it was solved. – Stephan Celis Aug 9 '13 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.