5

I'm sending an email using Mail Mime, based on a rule. I receive the email, and I can see in the HTML source that, the image has been translated,

E.g. <img src="cid:8215e4a9ecb00ce2ead763b488ee529e@dev.intranet"

But the image is not attached to the email. Do I need to explicitly allow Drupal to add attachments? I'm using Outlook if that makes any difference.

Update:

On further testing, I've noticed that when I use an embed image in the content, using HTML as a text type e.g

<img src="data:image/gif;base64,R0lGODlhDwAPAKECAAAAzMzM/////
wAAACwAAAAADwAPAAACIISPeQHsrZ5ModrLlN48CXF8m2iQ3YmmKqVlRtW4ML
wWACH+H09wdGltaXplZCBieSBVbGVhZCBTbWFydFNhdmVyIQAAOw=="
alt="Base64 encoded image" width="150" height="150"/>

it produced the following in the Outlook email,

<img alt="Base64 encoded image" height="150" src="data:image/gif;base64,R0lGODlhDwAPAKECAAAAzMzM/////
wAAACwAAAAADwAPAAACIISPeQHsrZ5ModrLlN48CXF8m2iQ3YmmKqVlRtW4ML
wWACH H09wdGltaXplZCBieSBVbGVhZCBTbWFydFNhdmVyIQAAOw==" width="150">

Note the missing "+".

I've turned off all text filters.

When I use plain text as the format, I get the content as expect, but of course Outlook does not think the message is in HTML, so displays the saw markup.

Any ideas on what could be causing the "+" to turn into a space?

1

Double check your setting on the mime mail configuration page.

In recent versions of the mime mail module there has been options added in relation to embedded images.

The option is called "Link images only". Generally I would turn that on as I don't see the need for embedding images in emails. You will generally have less issues with remote images.

There is also a permission for the mime mail module that relates to attached images, so check out the mime mail permissions too. Edit That permission is only a drupal 6 thing.

Update

In regards to your plus - space issue, what happens if you comment out the line

  $url = str_replace('+', '%2B', $url);

in the _mimemail_url function in the mimemail.inc file?

  • It looks like Mime Mail has one permission which is to alter settings. That's turned on for Admins which looks ok. I've checked the content type of the email "Content-Type: multipart/mixed;" and that looks OK. I'm using the latest version, 7.x-1.0-alpha2. Am I missing something? – user5681 Apr 25 '13 at 23:19
  • Sorry, turns out that permission is only a drupal 6 thing. It isn't in the drupal 7 version. – rooby Apr 26 '13 at 10:24
  • I added some about the "Link images only" and that the permission is a drupal 6 thing. – rooby Apr 26 '13 at 10:35
  • I added a Devel call to the module and confirmed the output was correct. I"m currently investigating whether there is a firewall or virus scanner stripping the content. – user5681 Apr 27 '13 at 4:08
  • I added an update, can you see if that changes anything? – rooby May 2 '13 at 5:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy