2

I am on Drupal 7 and I have the Smart Paging module enabled. When theming my module, I want the page numbers to appear as regular links. This seems to be the natural behavior. Here is the HTML available on the Devel module on the render section for [smart_paging]:

<div class="smart-paging-pager">
    <h2 class="element-invisible">Páginas</h2>
    <div class="item-list">
        <ul class="pager">
            <li class="pager-current first">1</li>
            <li class="pager-item"><a href="/node/178/devel/render/pagina/0/1" title="Ir para a página 2" class="active">2</a></li>
            <li class="pager-item"><a href="/node/178/devel/render/pagina/0/2" title="Ir para a página 3" class="active">3</a></li>
            <li class="pager-next"><a href="/node/178/devel/render/pagina/0/1" title="Ir para a próxima página" class="active">próx ›</a></li>
            <li class="pager-last last"><a href="/node/178/devel/render/pagina/0/2" title="Ir para a última página" class="active">fim »</a></li>
        </ul>
    </div>
</div>

The problem is that the links to the pages 1, 2, 3... are being replaced with a select list box with the options Page 1, Page 2, Page 3. I don't know how to change that behavior and make the links render as... links, exactly the way the HTML is showing.

I am using the Omega theme and I know it is not the theme replacing my pager because if I switch to another theme, the same change is applied to the pager... Do you know where I can configure the pager display? Do I have to go to template.php? Thank you.

1

I found the solution: go to the Smart Paging settings page and uncheck "Use javascript pager as progressive enhancement for Drupal native pager"... as simple as that...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.