5

drush vset latest_version 6.34a

latest_version was set to "6.34a"

So far so good.

drush vset latest_version 6.34

latest_version was set to 6.

Hmm...

drush vset latest_version '6.34'

latest_version was set to 6.

drush vset latest_version "6.34"

latest_version was set to 6.

  • What happens if you explicitly set the type to string? – mpdonadio Apr 29 '13 at 17:06
  • Pretty sure this is a bug in _drush_variable_format(). It uses is_numeric() instead of is int(). I would post in the issue queue. – mpdonadio Apr 29 '13 at 17:10
  • @greg_1_anderson That was quick :) I was going to investigate this further when I got home from work, with the hopes of giving you a patch. – mpdonadio Apr 29 '13 at 20:36
  • Wow, yeah that was quick. Not sure why assumed it wasn't a bug. – Letharion Apr 29 '13 at 21:48
5

Turns out that calling Drush as follows does the trick.

<-- language: lang-bsh -->

drush php-eval "variable_set('latest_version', '6.34');"

It also turns out that this is a bug, and that awesome greg_1_anderson fixed it within hours of me asking the question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.