0

This question already has an answer here:

I can’t transfer a Drupal 7 website on my hosting place due to the following error. “Fatal error: Undefined class constant ‘MYSQL_ATTR_USE_BUFFERED_QUERY’ in includes\database\mysql\database.inc on line 46”

My hosting server is Godaddy windows plan.

For this issues, i found the following solution,

Please make sure PDO, PDO mysql is correctly installed. Also php_pdo_mysql should be enabled. You can do this by uncommenting extension=php_pdo_mysql.dll in php.ini and restarting apache.

But when i contacted the support system ,they gave the following reply.

How can we over come this issue by adding a php.ini file in root?Could you please show me the sample ini here.?

Go Daddy Support 5/3/2013 1:02 pm Dear Mohd,

Thank you for your reply. Please note that we cannot modify the server settings of the plan you are hosting on. If you need to modify the configuration of your plan you will need to do so through the php.ini file in the root of your hosting plan.

Please let us know if we can assist you in any other way.

Regards, Eddie P. Online Support


Mohd Qureshi 5/3/2013 5:04 am Dear Ashley,

PHP.ini is located in your Apache server and we have no access to this files.You are only authorized to make any changes in Apache server files.We cannot override your php setting by adding my php.ini file in the root folder.

Please check it with a tech guy and resolve my issue asap.

I don't like to argue with you.

Please do reply asap.

Go Daddy Support 5/2/2013 7:10 pm Dear Mohd,

Thank you for contacting Online Support. I understand that you are trying to move your website to your hosting account with us. Your php.ini file is not a file we can create or update for you. It is a file you will need to create and add to your hosting account.

Please let us know if we can assist you in any other way.

Sincerely, Ashley H. Online Support


Mohd Qureshi 5/2/2013 10:35 am

i am not trying to install Drupal in this server,I'm transferring a Drupal website from dev to the go-daddy server.The files are almost completed ,DB also transferred.

Please note the error got when i checked the url

"Fatal error: Undefined class constant 'MYSQL_ATTR_USE_BUFFERED_QUERY'"

When i searched on Drupal support and they told me to enable the following settings in php.ini.

Please make sure PDO, PDO mysql is correctly installed. Also php_pdo_mysql should be enabled. You can do this by uncommenting extension=php_pdo_mysql.dll in php.ini and restarting Apache.

Please update me asap.Client is waiting for the live site.


marked as duplicate by monymirza, Clive May 4 '13 at 8:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You can't enable PDO through a local php.ini; it's an extension, it must be installed and enabled by someone with admin access to the server machine. If your hosting provider is refusing to do that, your only option is to find another plan/provider. To be honest, a PHP hosting plan without PDO in this day and age is a joke...I'd jump ship as soon as possible – Clive May 4 '13 at 8:30
  • yes Clive you are right! – harikris May 4 '13 at 8:44

Browse other questions tagged or ask your own question.