1

In my site : http://www.indiacustomercare.com front page(which is not displaying correctly) I want to show 200 words in teaser for each article. I've changed it in Post Settings but does not work.

What could be the reason?

2

You need to Edit and Save again the articles to take effect.

I know can be painful if you have hundreds of nodes. If you google about it you will find scripts to do it like this http://befused.com/drupal/script-update-drupal-teasers

Or use the module retease http://drupal.org/project/retease

I advice you to take a database dump before testing these solutions, just in case.

  • I've done it but it does not change the teaser of my front page: indiacustomercare.com/blogs/admin . Previously this was (/node) was the front page but now I've assigned an article to be the front page. Pl. see the link, I've changed the articles and saved them, cleared the caches. But still it does not work! – AgA Jul 14 '11 at 9:39
  • Are you using the tag <!--break--> inside the node content? This will override that setting. – corbacho Jul 14 '11 at 13:37
  • no nothing. This issue surfaced within a month only. Previously it was working fine. – AgA Jul 15 '11 at 9:54
0

With views module you can customize look of front page how ever you wish. You can style predefined "front-page" view or make your custom view and make front page of it.

In view, include field teaser (and title, post date etc.). Trim output of teaser to any number of characters you like and thats it. I like to exclude HTML tags from output as well so images, flash and such don't brake my layout

Hope this helps.

  • 1
    Well first I should find the problem than look for alternative solution. – AgA Jul 14 '11 at 13:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.