0

When the textfield is left blank, a default value populates. But when a value is placed into the text field, that value should show on the front end. It currently does not.

I have admin rights to edit,view any pages. I have enabled everything for adminstartor roles under User Management->roles. Even then am unable to update a new value to that field. It is populating the default value.

  • Hi there, could you be more specific? Which field on which form are you trying to edit? Is it a configuration setting on an admin form, a node, or a form from a custom module? – Boriana Ditcheva May 8 '13 at 19:10
-1

You can change the field default text in the field settings page of the content type, for example:

admin/structure/types/manage/[your-content-type]/fields/[your-field]

You need to change [your-content-type] and [your-field] by the real values on your drupal website.

|improve this answer|||||
  • This does not answer the question. He does not want to change the default. He wants to figure out why data he enters is not saved in the database. – Triskelion May 8 '13 at 14:55
  • Maybe the question is not well explained and the title says "Override the default text field" so I am answering that. – rteijeiro May 8 '13 at 15:29
  • Thanks for your comments! Explanation of my quest:- A content type has a text field eg:-phone number the author is different for this content type. I want to edit the phone number field with my values. But when i give Eg:888(234) . It isn't taking my number, it s taking the default number which the author has. But i have admin rights for editing the fields but when i save it and see that content type am not able to see my number which i gave. – jessy May 9 '13 at 5:00
  • It's really weird. Do you have enabled content revisions or other modules related with content workflow? – rteijeiro May 14 '13 at 14:58
  • Hey i got it worked!. A small code change fixed this issue. I was unable to override my default value. So handled it by taking the values directly from DB when i enter it in front end! – jessy May 15 '13 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.