0

I have dedicated FreeBSD box, The email sending without smtp module is working perfectly but very slow. The receiver receives email after almost 15 mins. I checked the maillog it says delays and timeouts that means the server keeps on trying to send email again and again until it successfully sends one. This is consuming lots of CPU.

I am seeking help for configuring smpt module to use my dedicated box's smtp server,
I need help in following places where I have ???? sign:

#SMTP server settings
SMTP server -> smpt.mydomain.com  # Tested by pinging, its working
SMTP backup server -> mail.mydomain.com  # Also verified by Ping
SMTP port -> 25
USE SSL

#SMTP Authentication
Username -> ???????
Password -> ???????

I tried using localhost, also username and password of the dedicated box or leaving both lines blank which gives me:

Unable to send e-mail. Contact the site administrator if the problem persists.

also checking the debug log doesn't show any log, it says check admin/reports/dblog but when I got to the link it just shows me the contents from admin/reports no any dblog

2
  • As regards the absence of reports it sounds like you haven't got DB logging turned on. You need to enable the core Database Logging module. Also I am not sure that sending to a local SMTP server will solve your delivery problem. Why so many retries? An SMTP server may perform as badly as your MTA, if it's something like a local DNS issue, for example. – Alfred Armstrong May 12 '13 at 16:54
  • Thanks for pointing to the Core->Database Log I turned it on and I can see the log now. I can successfully send test email using gmail smtp but when I send other emails I get SMTP Error: Could not connect to SMTP host – user12947 May 12 '13 at 17:53
0

Most providers block smtp ports, I had to use a mail redirection service when I set this up.

If the message gets through after 15 minutes though, I suspect you have a mail server misconfiguration. Nowadays, I usually go for a much simpler approach, I use google's smtp server to send the emails.

An easy way you can test if port 25 is blocked is by connecting by SSH to a remote server, then trying to telnet on local server port 25.

telnet mail.port25.com 25

If the port is open, you should get a response similar to this:

Trying 69.63.149.30...
Connected to mail.port25.com (69.63.149.30).
Escape character is '^]'.
220 mail.port25.com (PowerMTA(TM) v4.0) ESMTP service ready

Another thing to check, if you are using qmail make sure the trigger file has proper permissions. qmail/queue/lock/trigger should be prw--w--w qmails:qmail.

1
  • Yes I get the same response as you said for telnet and only port 25 is open for mail server. I could have used gmail but it sends email with myinfo@gmail.com however I want to send it via info@mydomain.com. I don't know about misconfiguration in mail server, as I haven't configured one. Without even touching it the mail was transferred (although slow) so, I haven't done anything in mail server settings. – user12947 May 12 '13 at 16:10
0

It wasn't so difficult to use my hosting providers smtp, instead of having my own. What I did is:

#SMTP server settings
SMTP server -> smpt.myhostingprovider.com
SMTP backup server -> mail.myhostingprovider.com
SMTP port -> 25
USE SSL

#SMTP Authentication
Username -> my-email@myhostingprovider.com
Password -> my email's password

Now, it is working perfectly, no delays !!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy