0

i have installed drupal 7.1 on PHP Version 5.2.17 .....now the server people is going to upgrade the php/mysql to a higher version like 5.3.3 ..is there any problem to the current drupal 7.1 websites running ?

Please advice me.

3

It's impossible to say whether your specific setup, with your specific site, will or will not have problems after a PHP upgrade. You'll need to set up a test environment that mirrors your live server as much as possible - and test it. It's unlikely, but you may have contrib modules installed that rely on PHP 5.2, so you need to check your specific installation.

From my own experience, before I upgraded to 5.4 some months back I was running many, many Drupal sites on 5.3 (though not versions as old as 5.3.3, that's pretty old these days). In over a year on dev/test/live I've never seen a single Drupal problem that was caused by the PHP version.

On another note, you really need to update your version of Drupal. We're currently on 7.22 and there have been a lot of security/bug fixes since the release you have installed.

You might also want to have a look at the PHP5.3 compatibility group, there's more detailed information there.

|improve this answer|||||
  • PHP 5.3.3 is old, but it is what CentOS 6.x and some other Linux distributions are shipping with by default. – mpdonadio May 14 '13 at 13:03
  • @MPD Excuse any ignorance here (I'm more an Ubuntu man), but the last time I installed CentOS 6 it was at 5.3.19 (this was maybe 3 months ago). Updates brought that up to I think 5.3.23 as of writing this. Are people just not updating their servers? Seems a risky game to play – Clive May 14 '13 at 13:33
  • The official RPMs from the CentOS repositories are 5.3.3; and they do get patched, but are stuck at that version. You can override PHP and MySQL using the IUS repos, and get PHP 5.3.23 and MySQL 5.5. I have servers with both (and yes, I do apply updates :). – mpdonadio May 14 '13 at 13:41
  • Ahh ok that makes sense, I don't recall updating the package repos but I must've done :P – Clive May 14 '13 at 13:47
2

There was several security issues between Drupal 7.1 and current 7.22, so you should upgrade anyway. If you will not, you can expect problems no matter if php will or will not be upgraded. And 7.22 works OK on PHP 5.3.x - unless you are using custom or outdated modules that doesn't.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.