I have installed and enabled the panelizer module and enabled the node_view template system page on the Page Manager administer pages page. I enabled panelizer for the Basic Page content type and created a new page. I clicked the panelizer tab and used the builder layout to create a new row below my body content. I added a region to the row and used the menu to add an existing node to that region.

It looked fine it preview so I saved it and went checked out the actual page where I saw the node content but not any of the panelizer content. The content in my added rows and regions did not display.

I tried uninstalling panelizer and re-installing but it still isn't working. Did I forget something?

  • Have you read the Installing Panelizer section in module page ?
    – niksmac
    May 20, 2013 at 3:56
  • @NikhilM yes I followed the steps. download install and enable the module, enable node_view in pages manager, configure panelizer to enable it for the node type. May 20, 2013 at 4:02
  • Did your content suddenly appear after clearing all of your caches? I'm experiencing this issue, but my content comes back after drush cc all. Jan 29, 2014 at 21:28

2 Answers 2


Make sure you enable panels node template at admin/structure/pages.

  • It's a shame how I forget this all the time! Jan 29, 2015 at 18:06

Panelizer 7.3.1 I had this same problem.

Panelized content shows preview, but when I view the live page, it looked like a regular, un-panelized node.

Turned on and off everything I could think of. Pulled out my hair...

Finally, I looked at the Display tab of my content type, and clicked open the Custom Display Settings. I turned OFF "use custom display settings for view modes: Full Content and Teaser". Suddenly my nodes were panelized. Click back on "Full Content", and panels disappear.

I don't know why this matters. Also, I'm using only Default-Panelize & Default-Provide Default Panel for my content type in the Panelize Configuration page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.