I'm having a kind of weird problem with the Context module in my Drupal 7 environment. I have the module installed and enabled, however, when I go to Structure --> Context --> Add, the Add Context Admin UI appears and under "Conditions" whenever I select one of the choices, the box to the right of it does not activate like it should, so I cannot put in a path or whatever. Nothing at all happens. It's the exact same for the "Reactions" as well.

It works fine in my development environment and the environment with the problem was migrated from the development environment, so I don't understand why it won't work.

I have tried completely uninstalling the module (including deleting the 'Context' folder from the server) and re-downloading and re-installing, flushing the caches, etc. Everything I can think of and I still get the problem.

Is this a problem anyone else has seen and how do I fix it?


  • Sounds like a Javascript error. Display the Javascript console using a dev tool such as Firebug and you'll probably see it. May 29, 2013 at 8:24
  • Thanks for the answers guys. I have no doubt the problem is the infamous ".$cookie is not a function" issue that has to do with mod_security, but I, for the life of me, cannot find a work around that works. I am still searching and will update if I can get it to work.
    – gev125
    May 29, 2013 at 17:29

1 Answer 1


I had the same problem with the "blocks" section.

In the blocks section, you need to select the block(s) you want to add in a template region from the right panel where there is a list of all the blocks. Then click the + sign of the corresponding region.

As for the condition problem, that is weird have you tried in different browser?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.