0

I've got a filter criteria saying field xyz = NO. Old nodes meeting the criteria above do not get picked up by the filter. When I edit the node, and resave it, only then they appear in the view. Is there a reason for this?

1

Yes this is possible. You will have to create two or more filter groups which will be separated with an OR condition.

Click "And/Or, Rearrange Filter Criteria" from the drop down menu of the Filters section and then click "Create New Filter Group". After that drag the filters you want in the new filter group and change the condition separating the groups to OR from AND. I would do it as follows:

1st group

Content: Published Yes And

Content: Type = News And

Content: Xyz (xyz) = Yes

OR

2nd Group

Content: Published Yes And

Content: Type = News And

Content: abc (abc) = Yes

  • Thank you @Billy-kouroublakis! I did eventually try that, but the view only seems to be picking up the newly created or edited nodes. Is this normal? Once you change the field name in the content type, does this change the database in such a way that i need to edit every single node and redo all the selections? Oh, how can I have the same filter in more than one group? I can only move them between groups, cant copy them :S – kine456 May 17 '13 at 7:25
  • 1) No that's not normal unless you have added a node post date filter or a content:new filter or maybe it's a pager issue. 2) You can have the same filter by simply adding that filter again and dragging to a different filter group. – Billy May 17 '13 at 8:00
  • 3) Of course not. Changing the field name in the content type does not require you to change it for every node in the database. – Billy May 17 '13 at 8:14
  • Thanks again @Billy I've got a filter criteria saying field xyz = NO. Old nodes meeting the criteria above do not get picked up by the filter. When I edit the node, and resave it, only then they appear in the view. Is there a reason for this? – kine456 May 20 '13 at 0:16
  • @kine456 Did you add the field xyz after you already had nodes of the content type whith the new field created? Nodes created before new fields are added will not have a field value, and NULL is not equal to NO (FALSE). If this is your issue, you need to either choose to count NULL values as TRUE or FALSE. FALSE, or NO, would probably be the most logical choice. – hampusn May 22 '13 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.