I'm a total newbie in Drupal.

I have successfully installed Drupal 7 in my WAMP installation, downloaded the Hierarchical Select module, put it in the sites/all/modules folder, and enabled it.

How can I now use it? I don't see any option.



It seems that the read me file for Drupal 7 needs updating. Things have changed from Drupal 6 to Drupal 7. You will find Hierarchical Select available as a widget for the term reference field. To use it, select it at for the field you want to use it for. Also you should use alpha releases at your own risk. They are expected to have bugs.


You should read the README file!

From the Drupal 7 version:


1) Place this module directory in your "modules" folder (this will usually be "sites/all/modules/"). Don't install your module in Drupal core's "modules" folder, since that will cause problems and is bad practice in general. If "sites/all/modules" doesn't exist yet, just create it.

2) Enable the module.

3) If you want to use it for one or more of your vocabularies, go to admin/content/taxonomy and click the "edit" link for a vocabulary. Now scroll down and you'll find a whole range of Hierarchical Select settings. All settings are explained there as well.

  • there is no /taxonomy in admin/content/ ... what vocabulary ? Picture of my content section – Daniel S Jul 19 '11 at 12:41
  • @Fdelgat If you use Drupal 7 there is. If you use another version, read exact details in the README file included. – googletorp Jul 19 '11 at 12:50
  • @Fdelgat Don't post username/password in comments! Check my updated answer for the solution. – googletorp Jul 19 '11 at 13:39
  • ok where do i select fields from ? – Daniel S Jul 19 '11 at 14:44
  • @Fdelgat If you dont know this you have a lot of reading to do, to get a basic understanding of Drupal. See the documentation section on drupal.org or search on google. – googletorp Jul 19 '11 at 15:01

If you have added a taxonomy term field ("tags") to the "Article" content type, then the settings for the Hierarchical Select module are at admin/structure/types/manage/article/fields/field_tags/widget-type.

settings page

You need to select "Hierarchical Select" as widget type.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.