2

I am using D7 and subtheming the commerce kickstart theme.

There is a view named Collection Products. I have added a field to the view called Product category: Description (indexed) that pulls in the taxonomy term description and places it above the product list. You can see the page here: http://freelance-graphic-designer.us/barmaiddev2/product-category/commercial-juicers

When it pulls this taxonomy term, all styling from the original content is lost. You can see how it comes in as one big block as h3. I have tried wrapping it in div containers in the wysiwyg editor on the original content page, but they just don't stay with it when it is pulled in by the view.

I have tried to style it within the view style settings with no luck.

I would like style the headings and body copy in my css style sheet and make it look more like the same content on its node here http://freelance-graphic-designer.us/barmaiddev2/commercial-juicers

Any suggestions? I am in a desperate hurry.

2 Answers 2

1

How I edited the Collection Products view

I needed to get rid of the surrounding the field. Did so by editing the view template file:

Copied the file views-view-list.tpl.php to a Template folder inside my theme folder and renamed it views-view-list--collection-products--page.tpl.php

Removed the around

See these sources on view templates:

http://drupal.org/node/352970

http://www.templatezine.com/2010/03/views-styles-and-theming-how-to-redefine-html-output/


In the View:

I added the field Taxonomy term: Rendered Taxonomy term Check "Exclude from display" View mode "Taxonomy Term Page"

Under Format > Settings Made Taxonomy term: Rendered Taxonomy term a Grouping Field


I also removed the header from the view since I had an image in the Rendered Taxonomy Term.

I also removed the 2 Taxonomy Term Name fields since the name came in with the Rendered Taxonomy Term.

0

Have you checked the configuration in the view for that field under "Rewrite Results" to make sure you don't have the box "Strip HTML tags" checked?

2
  • I looked and no, the "Strip HTML tags" remains unchecked.
    – user17651
    May 21, 2013 at 0:27
  • If it makes any difference, I have "exclude from display" checked in the field and then I have it as Grouping field Nr.2 under Format > Settings > Page: Style options
    – user17651
    May 21, 2013 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.