0

I have added a block to appear in the Content region, however it appears above the content of the node for French, but below the content of the node for English - which is strange as (as far as I know) they're both the same content type and should be the exact same templates.

Although the block name (and /url) is the same as the English nodes' url so maybe that's causing some problems which causes the block to appear after the nodes' content?

Is there any way to specifically define that you want a block to appear after the nodes' content? i.e. through weighting inside the module that adds the block?

EDIT: I've set the weighting on the blocks admin page, it's +15 for the block and the Main Page Content is -17. I also dragged it out of that region then back (without saving) before saving but still appears above for the French node and below for the English node...

EDIT 2: Seems to be a problem with the cache, at least a localhost version showed same error until I cleared cache... only problem is I don't have access to clear cache directly, could I code something in the module to clear the cache?

EDIT 3: So I have access to clear cache now, except the block is still showing up above for the French node and below for the English node... even though in Block Structure, the block is below the Main Page Content.

  • On the site, I don't have access to clear the cache, but I've been able to get the theme they use and set-up a more accurate dev site on localhost, which had the same problem: but then I cleared cache and was able to get it working. – dan2k3k4 May 22 '13 at 14:59
  • @GisleHannemyr I've been able to get access to clear cache but still same problem, though they also use memcache so maybe not all of the cache is cleared? – dan2k3k4 May 22 '13 at 15:49
0

Go to "Structure >> Block" and drop down your block to the main content.

  • I mentioned I had already gone there to change the weights, problem seems to be with the cache not being cleared (and I don't have access to do that). – dan2k3k4 May 22 '13 at 15:00
0

So I found out that the main content block was set to show up only for English and not for French!

Weird, since by default I would have assumed that if you didn't display the main content block then you wouldn't see any content. However I suppose Drupal has a default setting which must be a much higher weighting than any block can be (so why it was always appearing after all blocks!).

I set the main content block to be shown for all languages and it works perfectly now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.