2

I'm using Drupal 7.4 with Panels 7.x-3.0-alpha3. When creating a "New custom content" and using context keywords (eg %node:field-integer), the numeric integer field I'm adding gets pulled through with a comma (eg 7,234 instead of 7234). This also happens when adding Node (tokens) items.

The field in question does not have it's display formatted like that in Content Types > Manage Display either.

I believe that Tokens and Panels Context/Arguments is pulling this from the same location, but I'm not sure where it is configured like that.

I've also tried %node:field-integer-raw and -unformatted, as well as %node:field-integer:raw and :unformatted, but neither of those worked.

closed as off-topic by Letharion, Mołot, Free Radical, Patrick Kenny, AyeshK Oct 16 '14 at 11:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question was caused by a problem that can no longer be reproduced, was solved by a cache clear, or was a simple typographical error. While similar questions may be on-topic here, this one was resolved in a manner unlikely to help future readers." – Letharion, Mołot, Free Radical, Patrick Kenny, AyeshK
If this question can be reworded to fit the rules in the help center, please edit the question.

0

Just in case someone came here through a Google search, there is an answer to the specific question.

You can specify the default formatting of tokens by going in the Content Type in question, then in "Manage Display" tab, at the bottom of the page under "Custom Display Settings" you will have to enable the "Tokens" display.

The formatting that you choose for each field in this display will be used whenever you print the field through a token.

You could also use the Advanced Entity Tokens module, which allows you to specify a different view as an "extraction base" for your field formatters.

Edit:

Note that you can also create specific token formatters for profile2 entities by following the exact same method explained above. By default profile2 creates a single Display but there is still a Custom Display Settings option at the bottom of the page where you can enable the Tokens display and specify the formatters that you want to use for your Profile2 tokens wherever you use them (including Panels).

Not the answer you're looking for? Browse other questions tagged or ask your own question.