1

I just installed rapidssl certificate and I want to serve my cart pages using https protocol. I put all files inside apache2/ssl folder, edited default-ssl inside apache2/sites-available. The certificate is installed, but after visiting https://www.mysite.com or any link using https protocol, the browser gives me either the "It works page" or a not found page. It is probably due to path pointing to default directory.

I am assuming that I if put the correct path in the default-ssl file it should work. However, I read that having both http and https pages serving the same content is not good for SEO.

What would be the correct way of enabling cart* pages to automatically use https protocol?

0

If you care for SEO, consider using Metatag module:

Meta tags have additional uses like the Open Graph Protocol used by Facebook, specifying the canonical location of content across multiple URLs or domains.

For Drupal 6 there is Nodewords module, that was inspiration for Metatag as far as I know.

To force https where you need it, use Secure Pages. You can check "Switch back to http pages when there are no matches" to make sure pages not required to use SSL will never actually use it - that way you save both server's CPU load (as encoding isn't free) and problems with duplicated content. It's pretty convenient, and a good first step, but it should not stop you from setting canonical, of course.

  • I have installed Nodewordsmodule but I found out that it either creates canonical urls automatically (if you are on https site then canonical url would be https) or you can manually put url inside node edit form but again only url alias, which means that canonical url will be displayed with https if you are on https page. – loparr May 31 '13 at 16:25
  • I ended up using simple snippet inside template.php + secure pages module. See here drupal.stackexchange.com/questions/74819/… . Thank you for help – loparr Jun 1 '13 at 11:18
  • https problem seems to be a known thing: drupal.org/node/2009236 – Mołot Jun 3 '13 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.