2

I maintain a bilingual English/French website and the Language Switcher block is available on every page to allow the user to switch language. It works except on one particular taxonomy term page and all it's descendants:

When the language is set to English (default), the Language Switcher displays the correct links. English links to the EN page and French links to the FR page.

But when the language is set to French (i.e the user has clicked on French), both English and French options link to the french page (with /fr/rest-of-the-path/).

Any idea where the cause of this behaviour lies in?

  • I have the same problem on all pages, not just on a particular taxonomy term page. I am using language paths of the form "example.com" for the English site and "fr.example.com" for the French site. Drupal tells me that the language path for the default language may be left blank, so that's what I did. However, when I do set the language path "en.example.com" for the default language then the language switcher properly switches back to English after having switched to French first. I would prefer to not have an additional path for the default language though. Is this a bug in core? – deinqwertz Jul 30 '13 at 11:59
  • It turned out to be related to the Menu Token module. I fixed it by disabling it – znat Jul 30 '13 at 16:12
  • I've never had the module installed. Unfortunately, I still don't know what's causing the problem. – deinqwertz Jul 30 '13 at 17:51
  • Also see drupal.org/node/2053653 – deinqwertz Aug 19 '13 at 9:13
  • What Multilanguage Options has you Vocabulary? Is it set to Localize or Translation? – Lance Aug 19 '13 at 12:13
0

I think this happens because the term itself have no multilanguage path. From my experience the only way to have mulitlanguage path to a term is to create them by hand with an URL-Alias or by installing the [Pathauto i18n Taxonomy][1] Module. This helped me a lot

  • Please see my comment. This is not taxonomy page specific for me. – deinqwertz Aug 19 '13 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.