1

Preface

I have a fresh site install of Drupal. I'm fairly new to Drupal, but I feel rather confident with anything but module hacking right now. I've just finished about a month+ of editing and tweaking a play site to get comfortable with the Drupal theme engine and feel I am ready to move on. So I started putting together a real site using Drupal (rather than my play one).

I installed Entity API, Entity Reference, Views, and a few more.

Goal

My goal is to create Video Tutorials (custom content) that are listed inside Tutorials (custom content). This way I can create several Video Tutorials and use them in one, or more, Tutorials.

Attempts

I checked into Node Embed, which would theoretically work much better for this, but I have since given up as Node Embed requires installing and configuring an outside (non-drupal) plugin and the last time I tried to get that WYSIWYG editor installed it took me forever and I don't want the hassle.

Issue

I have just attempted to create the Video Tutorials and Tutorials custom contents.

I created Video Tutorials first. I have not edited the custom content fields. It has the generic fields for now.

Then I proceeded to create the Tutorial custom content type. I created a new field for it [field_tutorial_videos] that is supposed to be an Entity Reference to Video Tutorials.

The problem is I get this error block as soon as I create that field and it shows up everytime I click to edit this field...

Notice: Undefined property: stdClass::$nid in entity_metadata_no_hook_node_access() (line 619 of .../sites/all/modules/entity/modules/callbacks.inc). Notice: Undefined property: stdClass::$vid in entity_metadata_no_hook_node_access() (line 620 of .../sites/all/modules/entity/modules/callbacks.inc). Notice: Trying to get property of non-object in entity_metadata_no_hook_node_access() (line 620 of .../sites/all/modules/entity/modules/callbacks.inc). Notice: Undefined property: stdClass::$nid in node_access() (line 3002 of .../modules/node/node.module).

I have read through the README on both ENTITY API and ENTITY REFERENCE and I get nothing that makes sense. I have no idea what to do from here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.