I've got a custom content type ("charity listing"). Nodes in this content type should have the automatic alias charities/view/[name-of-charity]. They do indeed have this alias, when I try to edit a node the alias is there. However, typing the URL alias into the browser gives me a 404 error.

I have tried re-generating all the automatic URL aliases. Still doesn't work.

Help much appreciated!

  • Did you check that the path aliases are pointing to the correct URL? May you show a screenshot showing the editing page for one of those path aliases?
    – apaderno
    Commented Jul 21, 2011 at 13:13

1 Answer 1


Do you have any folder's in your root directory called "charities" or is there any rewrite rule in your.htaccess file? I know it's a long shot, but I had a very similar problem once and this turned out to be the cause.

Also, try putting "?q=" before the alias when you type in the url and see if that works (e.g., http://yourdomain.com/?q=alias/path). it will point to problems related to my other suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.