2

I just updated my site from 7.10 to 7.22 and now I am getting a Access Denied error on images that i'm uploading. My files folder is already 777 and everything else in there. Anyone know how to resolve this issue or what is causing it exactly?

enter image description here

I added the following into my settings.php file:

$conf['image_allow_insecure_derivatives'] = TRUE;

It got the images access denied error fixed, but this leaves your site insecure and undoes what it was suppose to secure.

  • I hate to be the one to say this but... have you updated db/cleared cache/rebuilt registry? – beth Jun 5 '13 at 16:40
  • how do you do that ? – Patoshi パトシ Jun 5 '13 at 16:41
  • Updating the database should happen after any upgrade and can be done by going to /update.php or in drush as drush updatedb. Clearing cache and rebuilding registry are drush cc all and drush rr respectively. – beth Jun 5 '13 at 16:47
  • i did those things already. drush cc all | drush rr | drush updb ... same result... – Patoshi パトシ Jun 5 '13 at 16:56
  • What is throwing the 403? The act of uploading the images or viewing them? All images or just new ones? Can you show the full error message? It sound like you are running into the itok problem and have some code making URLs by hand. Can't tell without mee info, though. – mpdonadio Jun 5 '13 at 18:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.