0

I have a file field called Video for a content type called Tutorial Video.

My settings are thus:

Allowed file extensions: txt, mp4

Maximum upload size: [empty]

The maximum upload section also has this text:

Enter a value like "512" (bytes), "80 KB" (kilobytes) or "50 MB" (megabytes) in order to restrict the allowed file size. If left empty the file sizes will be limited only by PHP's maximum post and file upload sizes (current limit 100 MB).

When I try to upload a 62MB MP4 video the Video field has (underneath the File Upload button) the following text:

Files must be less than 100 MB.

Allowed file types: txt mp4.

After I select the file and hit upload I get the following error message:

An unrecoverable error occurred. The uploaded file likely exceeded the maximum file size (100 MB) that this server supports.

I have requested my host upgrade my limits. They said they have set it to 250mb. I edited my php.ini and changed that to 500mb. I'm lost...

  • Do you see any more details in watchdog? – hw. Jun 8 '13 at 4:30
  • What is watchdog? – randomblink Jun 10 '13 at 19:13
1

The upload_max_filesize parameter in php.ini (or accessed elsewhere) must follow the file size naming that PHP understands:

upload_max_filesize = 100MB  // NO
upload_max_filesize = 100 MB // NO
upload_max_filesize = 100 M  // NO
upload_max_filesize = 100M   // YES

Also keep in mind that many shared hosts will cap this value at a higher level. So ask your host and use something reasonable like 25M or 50M - just putting in a ridiculously high value like 500M won't necessarily help you.

0

After contacting my hosting company they said it was a problem with my php.ini file and they resolved it. I did not get any further explanations.

  • As a side note, you often cannot edit your php.ini file on hosted sites. Even if it acts like it's letting you do so, unless your webhost specifically allows that, your changes will not be saved. – rrr45 Dec 1 '14 at 21:03
  • Usually this have to deal with the php.ini file. – darol100 Jan 4 '15 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.