-2

I have installed Acquia Dev Desktop on my Windows 7 PC. I cannot import the new Drupal site from its control panel. Whenever I try to do it, it shows the following error:

Cannot write file C:\Windows\system32\drivers\etc\hosts

I don't know how to solve it. I have attached some images with this mail.

I have Nod32 antivirus software installed on my PC.

3
  • Welcome to Drupal Answers :) This site is specifically for questions about the Drupal CMS (see the FAQ for more information). This question appears to be about Windows permissions and as such is off-topic here. – Clive Jun 10 '13 at 12:09
  • go to C:\Windows\system32\drivers\etc\hosts and right click on file, uncheck readonly and try again :) – Yuseferi Jan 24 '15 at 8:56
  • My antivirus was blocking edits to the hosts file. Try adding acquia dev desktop as an exception or temporarily turning it off during site creation. – blu Nov 23 '18 at 15:25
2

For the permission issue, I suggest you also try the following steps.

Take ownership of the hosts file and change the permission for it

=================================

  1. Right click on hosts file and click “Properties”.

  2. Switch to “Security” tab and click “Advanced” button.

  3. Switch to “Owner” tab and click “Edit…”.

  4. Highlight your user account or administrators group and click “OK” twice to quite the “Advanced Security Settings” dialog box.

  5. On the “Security” tab of “Properties” dialog box, click “Edit…”.

  6. Highlight Administrators group, check the box for “Full control” under “Allow” and click “OK”.

Not the answer you're looking for? Browse other questions tagged or ask your own question.