2

I'm using workbench core, which so far is providing the workflow that I need (well, almost).

The workflow is:

  • Primary editor writes a new node, and leaves it unpublished.
  • When the Primary editor is finished, he edits the node and changes the 'author' field to the new editor who will continue editing.
  • The New editor accesses his workbench page to (should be able to) see the unpublished node in his article list, where he continues to edit.
  • The New editor publishes the node after he has finished.

The problem is that the article never shows up in the New editor's article list on his Workbench page. However, when viewing the Content list, the article shows correctly and shows that he is indeed the owner / author. There is something wrong with Workbench that doesn't recognize new ownership of nodes (via the author field).

Is this a bug? Configuration setting? All I want to do is change the author of this node and it show up in his workbench. I am hoping I can do this without having to add any more workbench related modules.

To me it feels strongly like a configuration issue with the view that was supplied by the Workbench core module, but no amount of fiddling with it has proved productive. I think I'm just missing something. Plus, I'd prefer not to have to hack a module.

Here is a Drupal.org thread about it, however, no one has looked at the issue for months.

https://drupal.org/node/1921798

  • Just to confirm, you are not also using Workbench Moderation? – mpdonadio Jun 10 '13 at 23:37
  • I am not. Just the core workbench module is enabled. I would like to avoid installing anything else unless I absolutely have to. – blue928 Jun 11 '13 at 1:27
  • Cool. There is a related issue with Workbench Moderation. I think the issue is with the View using the uid of the first revision and not the current revisions. I would need to find a site of mine to double check this, though. – mpdonadio Jun 11 '13 at 12:58
  • Do you mean "My edits" or "Recent content" pages? – Mołot Jul 11 '13 at 7:09
  • @Mołot After clicking on "My workbench" in the top left, the article does not show under "my edits" or "my recent content" even though the ownership (author) of the article has changed. As MPD suggested, this could be based on the revision ID, but I have tried altering that to be author id with still no luck. But, I could have not been editing it correctly. – blue928 Jul 11 '13 at 11:55
3
+250

Workbench uses Views to render it's data. The trick - whilst new user is now considered author of a node, last edit was not his. So it will not be seen in "my edits".

Go to http://example.com/admin/structure/views/view/workbench_edited/edit. You will see:

Filter Criteria

This filters by revision's author. Not what you want. What you need is to filter by node's user. But this view does not have a relationship to content author: relationships

Add missing relationship: add relationship from content to it's author

Filter is still using wrong relationship: old filter settings

Make it use proper one: new filter settings

Done. Repeat for other views as needed.

  • you are the King. I was looking for something similar views related with workbench.... but your suggestion about relationship was perfect place to dig in.... thank you... – user12947 Oct 2 '13 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.