1

I tried to change the domain name of the existing site and now when I try to access the domain, it comes up with the drupal install screen.

Initially the domain name was stage.othercompany.com and now I changed the domain name to stage.mycompany.com. I changed the folder mapping in sites.php and cleared all the cache in the Drupal database. I have also restarted the Apache server but still I get only the install screen. Please help with this issue. Is there any other setting that I have to change? I have also changed the $base_url variable in settings.php in the respective multi site folder.

Update:

I checked the file_managed and file_usage table and both are empty.

I tried creating a directory called stage.mycompany.com under stage with all the module, theme,files folder and setting files from stage.othercompany.com folder and it seems to work now. I also tried with a symlink to the folder and that works as well.

My doubt now is that drupal is not honouring the sites.php. Can can one point me in the right direction please.

sites.php

$sites['stage.mycompany.com'] = 'example.com';

and the folders in sites directory are

all, default and example.com

Thanks for your help in advance.

  • Can you share your sites.php contest, also what is the default folders name in sites directory? – ram4nd Jun 12 '13 at 20:26
  • Hi @ram4nd I had updated my question with the code in sites.php and directory names in sites folder. kindly help me on this regards. Thank you. – Drupal Developer Jun 13 '13 at 0:16
  • Just a quick observation... You said you changed the $base_url variable inside the file setting.php -- was that a typo? If not, the file needs to be called settings.php, and the line with the database info needs to be overwritten to point to your existing database. Otherwise you'll get the install screen every time. – jerdiggity Jun 13 '13 at 3:21
  • Hi @jerdiggity. I checked the $base_url value once again and it seems to be fine. setting.php was a typo. The name is correct in the server. I would like to use the same database, so I didn change any variables in the database array. – Drupal Developer Jun 13 '13 at 8:27
  • Do you have the symbolic link done? You can create symlink with php if you don't have ssh access. It should be $sites['stage.mycompany.com'] = 'stage.mycompany.com'; Also the folder name should be stage.mycompany.com and remove default. Maybe you can find this helpful: Drupal 7 multi-site on localhost – ram4nd Jun 13 '13 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.