6

If i do install Wysiwyg + CKEditor 3.6.6.1 ( 2013.02.20) + Media module in Drupal 7 then the upload functionality works on ckeditor. Here is my screenshot: enter image description here But, if i install CKEditor Drupal 7 Module + Media Module then the upload functionality do not working on ckeditor. Here is my screenshot: enter image description here So, how i can enable the Upload section in Media Module? Thanks

3 Answers 3

5

I found the solution:
in order to use the upload plugin, the user has to either have the Edit media or the Administer media permission.

0
0

There is a settings page for controlling media in wysiwyg that allows you to configure this.

It is at admin/config/media/browser

The setting in question is "Enabled browser plugins". Check the "Upload" box.

5
  • Drupal 6? i'm in d7..
    – rakibtg
    Commented Jun 14, 2013 at 5:09
  • That is in drupal 7.
    – rooby
    Commented Jun 14, 2013 at 5:31
  • Actually I only use media 7.x-2.x versions. Are you in media 7.x-1.x?
    – rooby
    Commented Jun 14, 2013 at 5:32
  • 1
    OK, i am not telling about wysiwyg configuration, because the latest version of CKeditor do not depended on drupal wysiwyg module, if i use Media module with the latest version of CKEditor then there is no upload option.: i.sstatic.net/Q2O7s.png any idea?
    – rakibtg
    Commented Jun 14, 2013 at 6:50
  • Ah sorry, I misread.
    – rooby
    Commented Jun 16, 2013 at 7:26
0

There's also a permission called 'Add and upload new files' under 'File Entity' which might help people. This added the missing Upload tab to the generic (non-CKEditor) media browser for me…

(Note you don't need the plupload module just for this - that's a fancy widget, whereas changing the permission just adds a standard Drupal file upload field.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.