-2

When creating a new view and then trying to save it, I get this error:

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'drupal.views_display' doesn't exist: INSERT INTO {views_display} (vid, id, display_title, display_plugin, position, display_options) VALUES (:db_insert_placeholder_0, :db_insert_placeholder_1, :db_insert_placeholder_2, :db_insert_placeholder_3, :db_insert_placeholder_4, :db_insert_placeholder_5); Array ( [:db_insert_placeholder_0] => 11 [:db_insert_placeholder_1] => default [:db_insert_placeholder_2] => Master [:db_insert_placeholder_3] => default [:db_insert_placeholder_4] => 1 [:db_insert_placeholder_5] => a:12:{s:5:"query";a:2:{s:4:"type";s:11:"views_query";s:7:"options";a:0:{}}s:6:"access";a:1:{s:4:"type";s:4:"perm";}s:5:"cache";a:1:{s:4:"type";s:4:"none";}s:12:"exposed_form";a:1:{s:4:"type";s:5:"basic";}s:5:"pager";a:2:{s:4:"type";s:4:"full";s:7:"options";a:1:{s:14:"items_per_page";s:2:"10";}}s:12:"style_plugin";s:4:"list";s:10:"row_plugin";s:4:"node";s:6:"fields";a:1:{s:5:"title";a:8:{s:2:"id";s:5:"title";s:5:"table";s:4:"node";s:5:"field";s:5:"title";s:5:"label";s:0:"";s:5:"alter";a:8:{s:10:"alter_text";i:0;s:9:"make_link";i:0;s:8:"absolute";i:0;s:4:"trim";i:0;s:13:"word_boundary";i:0;s:8:"ellipsis";i:0;s:10:"strip_tags";i:0;s:4:"html";i:0;}s:10:"hide_empty";i:0;s:10:"empty_zero";i:0;s:12:"link_to_node";i:1;}}s:7:"filters";a:3:{s:6:"status";a:6:{s:5:"value";i:1;s:5:"table";s:4:"node";s:5:"field";s:6:"status";s:2:"id";s:6:"status";s:6:"expose";a:1:{s:8:"operator";b:0;}s:5:"group";i:1;}s:4:"type";a:4:{s:2:"id";s:4:"type";s:5:"table";s:4:"node";s:5:"field";s:4:"type";s:5:"value";a:1:{s:7:"teznews";s:7:"teznews";}}s:3:"tid";a:5:{s:2:"id";s:3:"tid";s:5:"table";s:14:"taxonomy_index";s:5:"field";s:3:"tid";s:5:"value";a:1:{i:0;s:1:"1";}s:10:"vocabulary";s:4:"tags";}}s:5:"sorts";a:1:{s:7:"created";a:4:{s:2:"id";s:7:"created";s:5:"table";s:4:"node";s:5:"field";s:7:"created";s:5:"order";s:4:"DESC";}}s:5:"title";s:11:"Latest News";s:11:"row_options";a:3:{s:10:"build_mode";s:4:"full";s:5:"links";b:1;s:8:"comments";b:0;}} ) in views_db_object->save_row() (line 2224 of D:\xampp\htdocs\drupal\sites\all\modules\views\includes\view.inc).

I have struggled with this for a while and have used SQL snippets to create tables which were previously 'missing'. I have also googled it extensively, without seeming to find an answer, and sure that someone will understand what the problem relates to immediately. This is the first time I have come up against it. This is a fresh install of drupal 7.22 and I have never experienced this problem previously whilst building drupal sites.

I have tried updating everything and wondered if there was some way to install a clean version of 'views' in core or if this related to another problem.

Any advice from a more skilled set of eyes would be invaluable.

Thanks

Ed

closed as too localized by kiamlaluno Jun 23 '13 at 19:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

1
'drupal.views_display' doesn't exist.

That pretty much sums up the problem. The table wasn't created in the initial setup of views. Without knowing more I can't tell you exactly what's going on but a couple of things you could try is to run update.php and check for the issue in the views queue. You may have a mysql issue as well that's not allowing the table to be created.

Good luck!

  • Thanks! I reinstalled drupal and did a new database and that fixed it. A shorter workaround as it happens. – user2513969 Jun 24 '13 at 15:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.