0

I have the unique parameters for my product. Sometimes I want to display some parameters, and sometimes I don't. So, I defined them in my product type.

My question is how do I display these fields for a product display? I don't want to create a duplicate when the values are already defined in the product type.

2 Answers 2

2

Fields from the referenced product entity are automatically available on the product display node.

Set the fields to visible on the product at

admin/commerce/products/types/subscription-product/display

Then, set the fields to display at:

admin/structure/types/manage/product-display/display

Update: As noted by vintorg below when creating your product reference field on the product display node, ensure "Render fields from the referenced products when viewing this entity." is checked.

That should do it.

6
  • The only fields with a visible option (in product type) are the ones already displaying. The rest of my custom fields in my product type are "Default, Plain Text, Trimmed", etc.
    – vintorg
    Commented Jun 24, 2013 at 1:34
  • "Default, Plain Text, Trimmed" aren't fields, they are formatters for specific fields. Can you clarify your question? It sounds as though the fields are already available for display. Commented Jun 24, 2013 at 1:37
  • I'm sorry, yes, those are my available formatters in my manage display. It appears they are ready for display, but they don't show up on my product display.
    – vintorg
    Commented Jun 24, 2013 at 1:39
  • Also, the fields aren't available in my display. I'm expecting them to magically display on my product display. Is that not correct?
    – vintorg
    Commented Jun 24, 2013 at 1:41
  • Your product display settings must match the display mode, full, teaser etc.. Commented Jun 24, 2013 at 1:50
0

When I created my product reference field in my product display, I did not check "Render fields from the referenced products when viewing this entity."

I checked it, and now my product fields now render in my product display.

1
  • Ah yes, I had assumed that was checked. Glad it's sorted. Commented Jun 24, 2013 at 3:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.