5

I have this modules enabled in my Drupal 7 site:

I have configured Mail system to "format" mails with MIME Mail and "mail" with SMTP Authentication. This configuration is set as site-wide default class.

It works fine for register user email, but when send mail with webforms it doesn't use that configuration (It sends emails with a local smtp).

How can I make webform take mail system configuration?

This is what I did:

  1. Install smtp module and config to send mails with amazon ese service. (Using the test option of this module it was working fine)

  2. Needed to send html mails so I installed "mime mail" and "mail system" modules

  3. After enable both modules I have created a class with "mail system" module in this way:

    • Create a class with:

      format: MimeMailSystem

      mail: SmtpMailSystem

    • After that apply the new class to:

      Site-wide default class

      Mime mail module class

  4. Tested the result with post register emails (This was working fine, amazon ses with html emails)

  5. Installed "webform" module and create a contact form

  6. Webform is sending mails but is not using my smtp config, it's using my local sendmail server (I realize this when the email was detected as possible phishing and looked at the email header)

  7. This shouldn't be working like this, it should be using the site-wide default class defined in "mail system"

  8. Post register emails are still working

7

I found the solution for the problem, it's really easy by the way. I hope this is helpfull for somebody else.

What we need is go to:

admin/config/system/mailsystem

Then press "New Setting" link, select "Webform" in the combobox, leave the "key" field empty and save configurations.

Then a new option is enable as shown in the image:

New option

Then we only need to select the right class for Webform module and save.

That's all, i think this should work for other modules too.

  • When MimeMailSystem_SmtpMailSystem class is selected in webform module class. We are not getting "Send e-mail as HTML" option. – Syed Hashim Feb 15 '14 at 10:26
  • I'm getting the same issue with this. Is there a solution yet? It defeats the object of having mimemail if you can't allow it to send HTML mail. – kevin.coyle Aug 18 '14 at 9:46
  • I have no "Send e-mail as HTML" option either. – Henry Mar 8 '16 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.