0

I had OG working fine except I wasn't able to upload images to be displayed (but to still keep the File field for PDF uploads as private to just the group).

However I've gone through and removed the CKEditor module as people suggested to use WYSIWYG with CKEditor (js library) so I moved that.

Then I installed the IMCE - WYSIWYG bridge too and tried several things to get the images working.

They were working but I noticed PDFs were no longer private, now I seem to have narrowed it down to the OG field settings.

If I add the "Group Audience" field to the content type (which is set as OG group content), then I can no longer visit that page and get this error:

EntityMetadataWrapperException: Unknown data property og_group_ref. in EntityStructureWrapper->getPropertyInfo() (line 339 of sites/all/modules/entity/includes/entity.wrapper.inc).

As soon as I remove the Group Audience field, I can access the content type again (i.e. I can edit, add new etc. for this one content type). However I need the Group Audience field to keep the content secure/private.

1

Clearing the caches worked for me with a "drush cc all".

0

I'm still unsure why the error appeared, it might have been because I had renamed the content type (and also renamed the machine name slightly), I deleted and re-built the Group Field settings a few times and cleared the cache (several times) but nothing seemed to work.

Then I was thinking to create a new content type and try that, but when I created the new content type, and went back to verify things, I noticed the Group Field settings were working fine, seems some function somewhere hadn't been called and was only called to refresh the Group Field when new content types were added.

Anyway deleted the new content type as I didn't need to use it - as the old one fixed itself...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.