0

I am a newbie to Drupal.

I have just installed display suite to increase layout control. I am now getting a lot of notices like this:

Notice: Undefined index: title_value in link_field_update_instance() (line 1305 of /var/www/vhosts/viovia.org/httpdocs/sites/all/modules/link/link.module).

What is even more of a nusiance is that I can configure customs fields for blocks and dynamic fields, but they will not display on my screen.

Can anyone tell me if this is linked to the index problem above, or is it anohter problem entirely?

1

The error message you quote has nothing to do with Display Suite. It is caused by a bug in the Link module (as should be obvious from the error message you quote).

Here is a link to the relevant issue ticket. If you read through the long list of messages, you'll see that the fix for this bug was commited to the dev branch of the Link module on May 23 2013. It is not in the "recommended" release. The "recommended" release of the Link module is from February 9 2013, so it is quite old.

Try to install the dev branch of the Link module, and see if things improve.

  • Many thanks Gisle, I got hold of the dev version and overwrote the old "link" version and all the error messagess have gone. It hasn't changed the display suite behaviour yet though, but at least I understand the difference now! I'll keep working on it. – Andy Jul 3 '13 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.