I just began working for a company and am using Drupal for first time. I'm working locally on WAMP. I started by installing and configuring a few modules before making my own and everything worked fine. Then I needed to integrate it into the site. I downloaded the repositories and all dependency modules/themes needed, as well as exported from the server and imported into my machine the database Drupal was running on. That got the correct look/feel/content of the site. However, since then I have been unable to make any changes through the administrative menu/pages. I can't enable/disable modules, make configuration changes, etc. Here's where my troubleshooting starts:

I can enable/disable modules through Drush. I've verified my Drupal settings.php file has the correct database settings for the imported database. I've verified I can log into our dev server and edit things there. I've verified the user priviledges and roles databases transfered correctly. I've used Drush to add the "Superuser" role to myself. I've used Drush to log on as the root user. Since I can't change configuration of a module, I can't enable debugging through Devel.

I've spent hours trying things and searching online, and I'm out of ideas. The closest I've seen someone else post about is this:

Can't save settings after copying site to new server

However, the symptoms aren't a 100% match, as I can log out/in. Any recommendations would be appreciated.

  • If your site uses non-database session handling, like memcached or file sessions, symptoms can be considered identical. Working drush indicates database settings are all right, so it must be a problem with php. What happens when you hit submit on a form? "Can't" is broad term. White screen of death? HTTP 200 OK but no changes saved? HTTP 500?
    – Mołot
    Commented Jun 28, 2013 at 7:10
  • Problem is fixed now, but what was happening was the page essentially reloaded with the form fields blank again.
    – Mike Beck
    Commented Jun 28, 2013 at 15:05
  • 1
    possible duplicate of Can't save settings after copying site to new server
    – Mołot
    Commented Jun 28, 2013 at 15:06

3 Answers 3


Problem is fixed. Late last night I tried investigating why my attempts to enable Mod Rewrite were not working properly, and when I figured out how to enable it natively in WAMP instead of manually in .htaccess, it fixed the issue. Apparently I was having the exact same problem as the linked post, just with slightly different symptoms, and I must have been attempting to enable it wrong so I didn't feel it was the same issue.

For other users in the same situation, you can't enable Mod Rewrite in .htaccess to fix it, you have to enable it through the WAMP server interface. It's under Apache > Apache modules > Rewrite_modules.


Mike Beck answer fixed the issue for me. Try running 'sudo a2enmod rewrite' in your server and then restart the apache with 'sudo service apache2 restart'.

  • Just copied a drupal7 site into a vscode .devcontainer, and that problem occured. This was a fix.
    – user18099
    Commented Aug 3, 2022 at 14:39

you can try to install drupal again, but with Acquia Dev Desktop ( from my experience, it run drupal faster than WAMP). You can also install Admin Menu ("drush dl admin_menu","drush en admin_menu"). And then, when you have everithing, you can go to your phpMyadmin and export the SQL file, then copy the files of the site you are working on to the server you are migrating, modify the settings.php and import the SQL file to your server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.