0

On my page http://www.athleticedgefitness.com/, I added a drop down menu under Contact. The hover color is yellow but for some reason, I cannot find that color style in my colors.css. What I found is that the devtools show that the background color change is caused by a rule starting at line 44 in http://www.athleticedgefitness.com/sites/default/files/color/corporateclean-659c1a2d/colors.css?mp37st The rule is:

#header-menu ul.menu li ul.menu li a:hover, 
#header-menu ul.menu li.expanded ul.menu li.expanded a:hover, 
#header-menu ul.menu li.expanded ul.menu li.leaf a:hover, 
#navigation .block-superfish ul.sf-menu li li:hover, 
#navigation .block-superfish ul.sf-menu li li a:focus, #navigation 
.block-superfish ul.sf-menu li li a:hover, #navigation .block-superfish 
ul.sf-menu li li a:active  { background-color:#fbff24; }

But If I check in my colors.css, my rule actually looks like this:

#header-menu ul.menu li ul.menu li a:hover,
#header-menu ul.menu li.expanded ul.menu li.expanded a:hover,
#header-menu ul.menu li.expanded ul.menu li.leaf a:hover,
#navigation .block-superfish ul.sf-menu li li:hover,
#navigation .block-superfish ul.sf-menu li li a:focus, #navigation .block-superfish ul.sf-menu li li a:hover, #navigation .block-superfish ul.sf-menu li li a:active  { background-color:#1b1b1b; }

I have tried to clear the caches and everything but that didn't help either, any recommendations? This is in Drupal 7.x with the Corporateclean theme.

Thank you!

  • Well, there is webserver's cache, proxy cache, browser cache, sometimes Boost cache, ngnx or varnish cache... it's hard to be sure you cleared them all. – Mołot Jun 28 '13 at 14:34
  • @Molot, yes, I also used different browsers to confirm – stdcerr Jun 28 '13 at 15:10
1

Have you checked the css file route (Chrome will show that in the dev tool) that the website is reading? I use superfish as well, there are some css files for the menu bar in '.../sites/all/superfish/css/', but I also have my overriding style in my custom theme folder. Are you sure the browser is linking to the css file that you think it is linking to?

And, that happened to me once, probably is not your case, but I once forgot to save my css after editing it :P

Good luck.

| improve this answer | |
  • I don't exactly understand what you mean with the file route, canyou be more descriptive please? I'm not using superfish thus, there's no /sites/all/superfish/ - should I be using superfish? directory for my site... I did save my css file! :) – stdcerr Jun 28 '13 at 15:15
  • If you're not using Superfish it seems strange that you have CSS rules like #navigation .block-superfish... – Clive Jun 28 '13 at 16:25
  • @Clive I do not have a module superfish installed nor have I ever heard of that module at all before this thread... – stdcerr Jun 28 '13 at 17:40
  • @the_summer_bee I now installed and enabled superfish just to see what's happening but I still don't have a /sites/all/superfish/ directory, in my /sites/all/ dir, there's only libraries, modules & themes... any other idea? Thank you! – stdcerr Jun 29 '13 at 3:46
  • Hi, where did you get the css file from then? did you write it, or is it come with any other themes or modules? It is not important whether or not you have used superfish. The key thing is, the css file you think you are using probably is not the one the website is actually linking to. – the_summer_bee Jul 1 '13 at 9:41
0

Added and configured Nice Menus - can configure the style sheets properly with that, unsure why that yellow wouldn't disappear...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.