0

I installed the latest BOA-stable and after it RVM with Compass and SASS. According to the changelogs of BOA-2.0.4, I should be able to use Compass commands:

Fixes:

Allow all standard compass/sass commands in limited shell.

As root, I am able to execute 'compass watch', but I am not with the limited shell (as user o1.ftp). It says:

sh: 1: compass: not found
1

For me it didn't work in combination with RVM. I needed to install it the normal way:

- apt-get install ruby
- apt-get install rubygems
- gem update --system
- gem install compass

I think that because of the isolated gem installs that RVM creates, the limited shell user has no access to the commands.

| improve this answer | |
0

You should modify the .barracuda.conf file to include the installation of compass tools. There is an option _XTRAS_LIST where you simply include CSS

| improve this answer | |
0

Note that now BOA uses RVM for all gems by default. We have also fixed this for limited shell environment, so at least in the last few months it should work just fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy