0

Since that I have uploaded my files and my DB to an actual server, NONE of the pictures of the website show up. I already checked the permissions and it should be fine. I ran a general report. There was one serious warning in CTools:

The CTools CSS cache directory, ctools/css could not be created due to a misconfigured files directory. Please ensure that the files directory is correctly configured and that the webserver has permission to create directories.

I am working on that one right now. Could that be the problem? Any ideas?

  • just run update.php too .. in case you've upgraded anything – AgA Jul 3 '13 at 15:42
1

you will have to verifiy that your paths for drupal file systems, including the tmp directory are set correctly on /admin/config/media/file-system

These directories also need to be writable by the php process, so they usually need owner, or group write access rights. these can be chmod 755 if the process is running in the same group as the file owner, or in worst case chmod 777

| improve this answer | |
0

Drupal's file system might need to be updated since your server's directories are different from your local environment's.

| improve this answer | |
  • I changed the file directory in configurations from sites/all/files – hasdrubal Jul 3 '13 at 15:52
  • #from sites/default/files to /sites/default/files www/sites/default/files /www/sites/default/files none of them worked – hasdrubal Jul 3 '13 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.