2

Has anybody come across a warning message which appears when you preview content? This message only displays when the workbench access module has been installed and the following setting has been checked 'Require a Workbench Access form element'

The messages: "*Warning: array_keys() expects parameter 1 to be array, string given in workbench_access_node_form_element() (line 1465 of C:\wamp\www\dev\sites\all\modules\contrib\workbench_access-7.x-1.2\workbench_access\workbench_access.module).*

*Warning: Invalid argument supplied for foreach() in workbench_access_node_form_element() (line 1466 of C:\wamp\www\dev\sites\all\modules\contrib\workbench_access-7.x-1.2\workbench_access\workbench_access.module).* "

Cheers!

  • Did you already grant permission for all roles to moderate your contents? – heshanlk Jul 5 '13 at 19:40
0

You can find the related bug here and the patch here.

You can then download the patch into the workbench_access directory and execute

patch -p1 < 1935190-wa-array-keys_0_1.patch

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.