6

I am working on an old Drupal website. I disabled the Electric Embers subscribe module - to get rid of a newsletter subscription option to a dead list. Previously my website was in off-line mode, but otherwise worked. Now the website looks like pure text or code.

www.rachel.org

I checked the database and the ee-subscribe module is still enabled.

Unfortunately I didn't make a backup before turning off this module. However, I've never seen turning off a module cause so much havoc.

I currently cannot use my admin log in or do anything directly through drupal.

Update
When does Drupal 5 change the filename field in the system table? The problem occurs when it sets the "filename" field to "modulename.info" (or .install or .js) for 10-20 modules. I can manually set it to "modulename.module" but the fix only lasts an hour or so.

I don't think that cron is running as there are no cron jobs scheduled and I do not use poormanscron. However I don't know how to test this.

closed as too broad by kiamlaluno Aug 5 '16 at 13:52

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Anything in the server logs? – Chris Rockwell Jul 5 '13 at 20:49
  • 1
    If you still have a valid session cookie you can try going to www.rachel.org/update.php and see if that helps. Do you have drush installed? – Patrick Ryan Jul 5 '13 at 21:05
  • 3
    Before you do anything else, back up your site. The 'code' being displayed is actually the content of your .info files. These files are read to support the enabling and disabling of modules. Otherwise everything the bootstrap requires is in the system table. My hunch is that the disabling of your module did not complete for some reason and you are hung up mid-process. I would try disabling the module in the database. – Triskelion Jul 5 '13 at 21:51
  • I don't see anything in error_log (last updated 11 months ago), or watchdog table (probably emptied by cron - only 25 rows). I tried disabling the module in the database, but that didn't work. Backup is underway. – Aaron Kreider Jul 8 '13 at 19:39
  • Can I reset or stop the drupal "add"/"remove" module process? – Aaron Kreider Jul 8 '13 at 19:50
1

Try using Drush if you have installed it.

> drush dis your_module_name
> drush cc all
0

I've seen this before, although it appears your running Drupal 5.x, no longer supported nor secure. I forget why I saw it last time, but it shouldn't be hard to set straight. As Chris Rockwell indicates, check your server logs to see if there's any permissions related errors (i.e., can not access filex.php) I don't know what kind of host your own but ensure your permissions are correct. Here's the essential drupal page for this: https://drupal.org/node/244924

This page might nail it for you? https://drupal.org/node/172729

  • Where are the server logs? I've looked at watchdog and didn't find anything (possibly it was pruned by cron). I don't see anything in public_html (the error_log hasn't been updated in 11 months old). – Aaron Kreider Jul 8 '13 at 19:35
  • I changed it and settings.php now has 0644 permissions (but this hasn't helped) . They were 0444 when I tried to disable the module. – Aaron Kreider Jul 8 '13 at 19:45
  • While I'd love to help, if this is Drupal 5, then I must excuse myself. I wouldn't run something as vulnerable as a public-facing application stack beyond it's end-of-life. – Screenack Jul 8 '13 at 23:42
  • Well I don't know if I can upgrade it while it has this problem. – Aaron Kreider Jul 9 '13 at 18:45
  • But I might try upgrading as a way of fixing it. – Aaron Kreider Jul 9 '13 at 19:05
0

I went through the system table and changed all the filename values for modules to have .module extensions. So of the filenames had been set to .info, .install, or .js extensions.

Now the "website is offline" message appears properly and the admin user can login.

I still haven't figured out what caused the problem in the first place. I'd like to be able to install/uninstall modules without problems.

  • This fix only worked for a short time. And then the system table values for filename were set back to ".info", ".install", and ".js" for some of the modules. I'm guessing that the cron job is doing this. – Aaron Kreider Jul 9 '13 at 18:50
  • I changed the update_status_last value in the variables table to far in the future -- and now this fix appears to be holding. However, I still have no clue what the original cause is and I cannot add/remove modules or upgrade to Drupal 6. – Aaron Kreider Jul 18 '13 at 4:29
0

Make sure you did not set 0 (zero) for status field for any core modules. Because what you see on the page is all the .info file data. This means, Drupal does not work beyond reading .info file details. Also, check custom modules, if any, for debug code. Check also 'system' module.

Not the answer you're looking for? Browse other questions tagged or ask your own question.