0

I set path auto alias of content type page to:

[language]/[title-raw]

I am using Content Translation module.

I created english version of selected page. Alias was generated ok.

But even if I am admin, I have 404 when I want to view this page.

Could somebody give me any advice?

EDIT

I change pathauto alias setting to

[title-raw]

still 404.

If I use raw address of page (node/232) it works.

EDIT 2

After recreate page, alias works ok (:

1

In the Workflow settings of the type page you should choose Multilingual support: enabled or eabled with translation if you want to have the page in 4 different versions on their own.

If you simply choose enabled you can e.g. make as many path aliases as languages are active for one and the same page. If you choose "with translation" you can make translation nodes after creating the page. There is also a rules integration, that makes you all translation nodes automatically.

If you enable Multilingual support you will see in pathauto autmoatic section, that you can choose a path for every enabled language. The prefix you shouldn't use, because itis handled by drupal and/or modules itself. You can change the behaviour in the languages menu under site configuration.

  • Thanks, but all I have set properly right know and still 404. Ofcourse I cleared cache before. – Codium Jul 26 '11 at 15:31
  • How does the entry in your db table looks like? (url_alias) – user30370 Jul 27 '11 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.